reklama

Uvedly to dnes bezpečnostní firmy Check Point a Kaspersky s tím, že jde o jednu z nejvážnějších zranitelností odhalených v posledních letech s hodnocením deset na desetibodové škále nebezpečnosti.

Jde o velmi nebezpečnou zranitelnost třídy Remote Code Execution (RCE), která umožňuje útočníkům spouštět libovolný kód a potenciálně převzít plnou kontrolu nad systémem na napadeném serveru. Check Point podle svého dnešního vyjádření od pátku zastavil už více než 820.000 pokusů o zneužití této zranitelnosti. Více než 46 procent pokusů mají na svědomí známé hackerské skupiny. A pokusy o zneužití zranitelnosti registruje více než 36,8 procenta podnikových sítí po celém světě.

Podle antivirové firmy Avast jsou ohrožené známé internetové platformy jako Apple, Amazon, Steam, Twitter nebo Minecraft. "Zranitelnost umožňuje útočníkům přístup k cizímu zařízení. A to klidně jednoduše jako třeba odesláním speciálního textu do chatovacího okna zranitelné aplikace. Následně tak mohou zařízení infikovat malwarem, krást data nebo je jakkoli jinak zneužít. V nebezpečí nejsou pouze zařízení přímo připojená k internetu, útočníci se dokáží dostat i do vnitřních sítí, které tyto speciální vstupy následně zpracovávají za použití zmíněné knihovny Log4j," uvedl ředitel výzkumu škodlivých programů Avastu Jakub Křoustek.

"Na rozdíl od jiných významných kybernetických útoků, které se týkají jednoho nebo omezeného počtu programů, je Log4j v podstatě součástí každého javového produktu nebo webové služby a je velmi obtížné vše manuálně záplatovat. Ihned po odhalení zranitelnosti začaly hackerské skupiny skenovat internet a hledat zranitelná místa. Navíc se neustále objevují nové možnosti zneužití a obelstění ochran. Zranitelnost, vzhledem ke složitosti záplatování a snadnosti zneužití, bude mít dopad na organizace několik dalších let, pokud společnosti a služby nepřijmou okamžitě odpovídající opatření," dodal Daniel Šafář z české pobočky Check Pointu.

Na první pohled se zranitelnost snaží zneužívat zejména těžaři kryptoměn, ale je pravděpodobné, že to jen maskuje závažnější útoky například na banky, kritickou infrastrukturu a národní bezpečnost. Bezpečnostní týmy musí rychle reagovat, protože následky mohou být podle bezpečnostních firem zničující.

Nová zranitelnost je podle Jevgenije Lopatina z firmy Kaspersky obzvláště problematická. "Útočníci mohou získat úplnou kontrolu nad systémem, ale nebezpečná je i v tom, jak snadno se dá použít - dokonce i nezkušeným hackerem. Průběžně vidíme, jak se kyberútočníci snaží aktivně najít software, který by mohli napadnout,“ dodal.

Bezpečnostní firmy uživatelům doporučují, aby si stáhli nejnovější verzi knihovny 2.15.0. Ke stažení je na stránce projektu Apache. Firmy by také měly používat bezpečnostní řešení, které poskytuje komponenty zaměřené na prevenci zneužití, zranitelnosti a správu oprav.